Error: Value Cannot Be Null
Overview
When trying to connect to your Business Central data source, you see this message:
Accounts could not be loaded. The following error was reported:
Value cannot be null. Parameter name: type
Cause
Changes made by Microsoft to Business Central can affect how internal codeunits are named.
Resolution Process
-
Sign in to your Business Central account and search for Web Services.
-
Find the Data Source reference and remove it from the list.
-
Create a new Web Service for the Jet Data Source code unit and name it JetDataSource (no spaces).
-
For the new JetDataSource codeunit, ensure that the box for PUBLISH is checked and that the box for ALL TENANTS is not checked.
You are now done working in Business Central.
-
Open Windows File Explorer.
Ensure that Microsoft Excel is closed .
-
Navigate to the Reporting Intelligence Settings folder: %Appdata%\Reporting Intelligence and open the file Data Sources.xml for editing.
-
Find the <setting> name WebServiceCodeUnit and change the <value> to JetDataSource.
-
Save the file.
You should now be able to restart Reporting Intelligence Financials.
Open Excel and verify that Reporting Intelligence Financials can now properly connect to Business Central.
Every Reporting Intelligence Financials user will need to edit their Data Sources.xml file